Zgrzewarka ArduWelder

Dział Do it yourself - Zrób to sam - prezentacja urządzeń wszelkiego rodzaju wykonanych we własnym zakresie
Awatar użytkownika
saybot
Kierowca
Posty: 5
Rejestracja: 16 lut 2018, o 19:51

Re: Zgrzewarka ArduWelder

Postautor: saybot » 21 mar 2018, o 20:42

no właśnie jak to rozumieć, w jedym poście zaznaczyłeś na czerwono:
UWAGA !!
Zmiana konfiguracji przycisku zgrzewania, przycisk ma być NO (normalnie otwarty) a włączenie zgrzewania poprzez zwarcie pinu 8 do GND.

Widzę jeszcze jedną dziwną sprawę, jak łącze się przez kabel USB to na ekranie widzę komunikat "zgrzewanie" jak zewre pin 8 i GND, a jak uruchomie system przez zasilacz 12V to jest odwrotnie, czyli zgrzewanie następuje jak pin8 i GND są rozwarte
Awatar użytkownika
Sławek
Site Admin
Posty: 13479
Rejestracja: 21 gru 2011, o 22:12
Podziękował: 97 razy
Otrzymał podziękowań: 424 razy

Re: Zgrzewarka ArduWelder

Postautor: Sławek » 22 mar 2018, o 06:38

To nie ma znaczenia w jaki sposób jest zasilane arduino. Faktycznie od którejś wersji zamieniłem logikę przycisku. Jeżeli tak jest napisane w opisie do tej wersji to tak ma być. Jest tez wersja z dwoma czujnikami temperatury na prośbę jednego kolegi, tej wersji nie wgrywaj.

Pozdr
Awatar użytkownika
frycol
Kierowca
Posty: 3
Rejestracja: 20 mar 2018, o 07:24

Re: Zgrzewarka ArduWelder

Postautor: frycol » 26 mar 2018, o 01:01

saybot pisze:kurcze jednak mam trochę problemy, choćby ze stabilnością programu. Czasem muszę kliknąć kilka razy w enkoder aby przycisk zadziałał. Druga sprawa czy soft jest ustawiony w ten sposób, że przy zwarciu GND i pin8 to zgrzewarka powinna zgrzewać? Bo przy sofcie 3.0 jeśli piny nie są zwarte to zgrzewarka zaczyna mi zgrzewać czyli jeśli nie podłącze pedału to na dzieńdobry zgrzewarka zaczyna mi zgrzewać;/
Czasem również po chwili na ekranie pojawiają się jakieś dziwne znaki i soft nie zawsze ładuje się poprawnie po uruchomieniu.
Przy oprogramowaniu z buzzerem i podłączonym buzzerem ekran np sam się dziwnie rozjaśnia

Miał ktoś podobnie?

(sorry za odwrócone zdjęcia ale coś mi tak wstawia, nie zależnie czy obróce źródłowy plik)

IMG_0511.JPG

IMG_0512.JPG

Witam! Cały czas buduje zgrzewarkę czyli tak z 2 miesiące ale testy elektroniki robiłem wcześniej i mam ten sam problem z buzerem, tj zmiana podświetlenia po zadziałaniu buzera a dodatkowo wygląda a właściwie słychać jakby buzer po zgrzewie cały czas brzęczał. Pomaga dopiero odłączenie go. Enkoder też nie zawsze od razu łapie ale to nie problem.
Awatar użytkownika
Sławek
Site Admin
Posty: 13479
Rejestracja: 21 gru 2011, o 22:12
Podziękował: 97 razy
Otrzymał podziękowań: 424 razy

Re: Zgrzewarka ArduWelder

Postautor: Sławek » 26 mar 2018, o 06:40

Ściąg poprzednia wersje softu bez buzerra, to gadżet o który ktoś prosił, ja tego nie używam, przecież i tak wiadomo kiedy jest zgrzewanie.

Pozdr
Awatar użytkownika
saybot
Kierowca
Posty: 5
Rejestracja: 16 lut 2018, o 19:51

Re: Zgrzewarka ArduWelder

Postautor: saybot » 29 mar 2018, o 16:57

Może ktoś się orientuje czy są jakieś SSR'y którymi można sterować pod kątem mocy? w tej chwili działa to 0/1 a przydała by się opcja sterowaniem np 0, 25, 50, 75, 100%? Zgrzewam generalnie dosyć grubszy nikiel jednak kiedy muszę coś zgrzać cieńszym nawet przy najmniejszym czasie jest za duża moc. A chce jeszcze podkręcić trochę zgrzewarkę żeby grubszą miedź zgrzać, w tej chwili mi tylko 0,1mm zgrzewa, a to niestety za mała grubość na moje potrzeby
Awatar użytkownika
noisue
Kierowca
Posty: 3
Rejestracja: 15 kwie 2018, o 14:58

Re: Zgrzewarka ArduWelder

Postautor: noisue » 15 kwie 2018, o 20:42

Cześć,

Zrobiłem zgrzewarkę według Twojej instrukcji, chociaż ja użyłem arduino pro mini, ale program działa.

Niestety mam problem, gdyż zgrzewy rzadko się udają, tzn trzymają bardzo słabo i da się je łatwo rozerwać, rzadko kiedy rozrywa się taśma, w 80% przypadkach puszcze zgrzew. Często tez przeskakują iskry. Nie wiem co jest problemem
Czy może jest za mały prąð, może problem z jakością taśmy- chociaż próbowałem dwa rodzaje, czy problemem są elektrody.
Transformator jest z mikrofali 800W, przewody 50mm2. Napięcie na wtórnym 1,6V.
Elektrody są zaostrzone.

Próbowałem z różnymi czasami zgrzewu od 80 -200 ms, ale różnica w jakosci zgrzewow praktycznie żadna

Pod poniższym linkiem zdjęcia, na jednym z nich zgrzew, który się udał, ale jest to naprawdę rzadkość.
https://drive.google.com/open?id=1oqamZ ... TtSMRNlw_q

Co zrobiłem nie tak?
Awatar użytkownika
Sławek
Site Admin
Posty: 13479
Rejestracja: 21 gru 2011, o 22:12
Podziękował: 97 razy
Otrzymał podziękowań: 424 razy

Re: Zgrzewarka ArduWelder

Postautor: Sławek » 16 kwie 2018, o 06:19

Wstaw fotki jako załączniki do postu.

Pozdr
Awatar użytkownika
noisue
Kierowca
Posty: 3
Rejestracja: 15 kwie 2018, o 14:58

Re: Zgrzewarka ArduWelder

Postautor: noisue » 16 kwie 2018, o 07:57

W załączeniu fotki.
Zauważyłem, że w uzwojeniu pierwotnym jeden zwój jest przetarty i zostało tak ze 2/3 średnicy, ale to chyba nie będzie problemem.
Załączniki
IMG_20180415_174951-0.jpg
widok ogólny
IMG_20180415_174951-0.jpg (153.98 KiB) Przejrzano 210 razy
IMG_20180415_174951-0.jpg
widok ogólny
IMG_20180415_174951-0.jpg (153.98 KiB) Przejrzano 210 razy
IMG_20180415_174951-7.jpg
trafo
IMG_20180415_174951-7.jpg (123.43 KiB) Przejrzano 210 razy
IMG_20180415_174951-7.jpg
trafo
IMG_20180415_174951-7.jpg (123.43 KiB) Przejrzano 210 razy
IMG_20180415_174951-6.jpg
elektrody
IMG_20180415_174951-6.jpg (115.9 KiB) Przejrzano 210 razy
IMG_20180415_174951-6.jpg
elektrody
IMG_20180415_174951-6.jpg (115.9 KiB) Przejrzano 210 razy
IMG_20180415_174951-5.jpg
zgrzewy
IMG_20180415_174951-5.jpg (97.94 KiB) Przejrzano 210 razy
IMG_20180415_174951-5.jpg
zgrzewy
IMG_20180415_174951-5.jpg (97.94 KiB) Przejrzano 210 razy
Awatar użytkownika
Sławek
Site Admin
Posty: 13479
Rejestracja: 21 gru 2011, o 22:12
Podziękował: 97 razy
Otrzymał podziękowań: 424 razy

Re: Zgrzewarka ArduWelder

Postautor: Sławek » 16 kwie 2018, o 10:28

Elektrody muszą mieć ostre końcówki, ważny też jest mocny docisk.

Pozdr
Awatar użytkownika
noisue
Kierowca
Posty: 3
Rejestracja: 15 kwie 2018, o 14:58

Re: Zgrzewarka ArduWelder

Postautor: noisue » 16 kwie 2018, o 10:58

Elektrody są naostrzone na szpilkę. Spróbuje jeszcze zmienić uzwojenie na 3 zwoje 35mm2, bo 3 zwoje 50mm2 się nie zmieszczą. Może jak wzrośnie napięcie, chociaż kosztem prądu to będzie lepiej zgrzewać. Zdam relacje czy będzie lepiej.

Wróć do „DIY”

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 1 gość